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WEB SERVICES
LAB MANUAL

OBJECTIVE
e To implement the technologies like WSDL, UDDI.

e Tolearn how to implement and deploy web service client and server

LIST OF PROGRAMS
1. Write a program to implement WSDL Service (HelloService.WSDL File)

2. Write a program the service provider can be implement a single get price (), static bind () and
get product operation.
3. Write a program to implement the operation can receive request and will return a response in
two ways.

a) One-Way operation

b) Request - Response
4. Write a program to implement to create a simple web service that converts the temperature
from Fahrenheit to Celsius (using HTTP Post Protocol)
5. Write a program to implement business UDDI Registry entry
6. Write a program to implement

a) Web based service consumer

b) Windows application based web service consumer
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1. Write a program to implement WSDL Service (HelloService. WSDL File)

e Creating a HelloService Web Service

A

Open Netbeans 7.4
Open New Project - Java Web -> Web Application
Type Project Name HelloWorld
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Right Click on Source Packages and add new web service HelloService with package

org.me.Hello.

Open HelloService.java which is in Source packages - org.me.Hello and create web

service as follows:

package org.me.Hello;

import javax.jws.WebService;
import javax.jws.WebMethod;
import javax.jws.WebParam;

@WebService(serviceName = "HelloService™)
public class HelloService {

@WebMethod(operationName = "hello")
public String hello(@WebParam(name = "username") String user) {
return "Hello " + user + " I';

¥
¥

Now Right Click on Project Name HelloWorld, Build and then Deploy.
Test the web service

Expand web services and Right click HelloService and Select Test Web Service

Or use the following url in browser.
http://localhost:8080/HelloWorld/HelloService?Tester

To View WSDL file use the following url in browser.
http://localhost:8080/HelloWorld/HelloService?WSDL
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HelloService. WSDL Contents

<definitions targetNamespace=http://Hello.me.org/ name="HelloService">
<types>
<xsd:schema>
<xsd:import namespace=http://Hello.me.org/
schemaLocation="http://localhost:8080/HelloWorld/HelloService?xsd=1"/>

</xsd:schema>
</types>
<message name="hello">

<part name="parameters" element="tns:hello"/>
</message>
<message name="helloResponse">

<part name="parameters" element="tns:helloResponse"/>

</message>
<portType name="HelloService">

<operation name="hello">

<input wsam:Action="http://Hello.me.org/HelloService/helloRequest"
message="tns:hello"/>
<output wsam:Action="http://Hello.me.org/HelloService/helloResponse™
message="tns:helloResponse"/>

</operation>

</portType>

<binding name="HelloServicePortBinding" type="tns:HelloService">
<soap:binding transport=http://schemas.xmlsoap.org/soap/http style="document"/>
<operation name="hello">
<soap:operation soapAction=""/>
<input><soap:body use="literal"/></input>
<output><soap:body use="literal"/></output>
</operation>
</binding>
<service name="HelloService">
<port name="HelloServicePort" binding="tns:HelloServicePortBinding">
<soap:address location="http://localhost:8080/HelloWorld/HelloService"/>
</port>
<[service>

</definitions>

For study materials, lab manuals, Lecture Presentations, Video lectures, seminar topics & projects visit

www.btechsmartclass.com




Page 4 of 39

Definition: HelloService
e Type: Using built-in data types and they are defined in XMLSchema.
e Message : HelloRequest : firstName parameter ~ Helloresponse: greeting return value
e Port Type: HelloService operation that consists of a request and response service.
e Binding: Direction to use the SOAP HTTP transport protocol.
e Service: Service available at http://localhost:8080/HelloWorld/HelloService
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2. Write a program the service provider can be implement a single get price () and get
product () operation

getprice()
package com.ecerami.soap.examples;

import java.util.Hashtable;

/**

* A Sample SOAP Service

* Provides Current Price for requested Stockkeeping Unit (SKU)
*/

public class PriceService {

protected Hashtable products;

/**

* Zero Argument Constructor

* Load product database with two sample products
*/

public PriceService () {

products = new Hashtable( );

// Red Hat Linux

products.put(*A358185", new Double (54.99));

/I McAfee PGP Personal Privacy
products.put(*A358565", new Double (19.99));

}

/**

* Provides Current Price for requested SKU

* In a real-setup, this method would connect to
* a price database. If SKU is not found, method
* will throw a PriceException.

*/

public double getPrice (String sku)

throws ProductNotFoundException {

Double price = (Double) products.get(sku);

if (price == null) {

throw new ProductNotFoundException ("SKU: "+sku+" not found");
¥

return price.doubleValue( );

¥
}
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To generate a WSDL file for this class, run the following command:

java2wsdl com.ecerami.soap.examples.PriceService -s -e http://localhost:
8080/soap/servlet/rpcrouter -n urn:examples:priceservice

The -s option directs GLUE to create a SOAP binding; the -e option specifies the address of
our service; and the -n option specifies the namespace URN for the service. GLUE will generate
a PriceService.wsdl file.

Getproduct ()

<?xml version="1.0" encoding="UTF-8"?>

<definitions name="ProductService"
targetNamespace="http://www.ecerami.com/wsdl/ProductService.wsdl"
xmlns="http://schemas.xmlsoap.org/wsdl/"
xmlins:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:tns="http://www.ecerami.com/wsdl/ProductService.wsdl"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmins:xsd1="http://www.ecerami.com/schema">

<types>

<xsd:schema
targetNamespace="http://www.ecerami.com/schema”
xmlns="http://www.w3.0rg/2001/XMLSchema">
<xsd:complexType name="product™>
<xsd:sequence>

<xsd:element name="name" type="xsd:string"/>
<xsd:element name="description" type="xsd:string"/>
<xsd:element name="price" type="xsd:double"/>
<xsd:element name="SKU" type="xsd:string"/>
</xsd:sequence>

</xsd:complexType>

</xsd:schema>

</types>

<message name="getProductRequest"> <part name="sku" type="xsd:string"/>
</message>

<message name="getProductResponse">
<part name="product" type="xsd1:product"/>
</message>
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<portType name="Product_PortType">
<operation name="getProduct™>

<input message="tns:getProductRequest"/>
<output message="tns:getProductResponse"/>
</operation>

</portType>

<binding name="Product_Binding" type="tns:Product_PortType">
<soap:binding style="rpc"
transport="http://schemas.xmlsoap.org/soap/http"/>
<operation name="getProduct™>

<soap:operation soapAction="urn:examples:productservice"/>
<input>

<soap:body
encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
namespace="urn:examples:productservice"

use="encoded"/>

</input>

<output>

<soap:body
encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
namespace="urn:examples:productservice" use="encoded"/>
</output>

</operation>

</binding>

<service name="Product_Service">

<port name="Product_Port" binding="tns:Product_Binding">
<soap:address
location="http://localhost:8080/soap/servlet/rpcrouter"/>
</port>

<[service>

</definitions>
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3. Write a program to implement the operation can receive request and will return a
response in two ways.
a) One - Way operation
b) Request —Response

The <portType> element is the most important WSDL element.
WSDL - The <portType> Element

The <portType> element defines a web service, the operations that can be performed, and the
messages that are involved.

<portType> defines the connection point to a web service. It can be compared to a function
library (or a module, or a class) in a traditional programming language. Each operation can be
compared to a function in a traditional programming language.

Operation Types

The request-response type is the most common operation type, but WSDL defines four types:

Type Definition

One-way The operation can receive a message but will not return a response

Request-response | The operation can receive a request and will return a response

Solicit-response | The operation can send a request and will wait for a response

Notification The operation can send a message but will not wait for a response

One-Way Operation

A one-way operation example:

<message name="newTermValues">
<part name="term" type="xs:string"/>
<part name="value" type="xs:string"/>
</message>

<portType name="glossaryTerms">
<operation name="setTerm">
<input name=""newTerm' message=""newTermValues"/>
</operation>
</portType >
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In the example above, the portType "glossaryTerms" defines a one-way operation called

"setTerm".

The "setTerm" operation allows input of new glossary terms messages using a "newTermValues"
message with the input parameters "term" and "value". However, no output is defined for the

operation.

Request-Response Operation

A request-response operation example:

<message name="getTermRequest">
<part name="term" type="xs:string"/>
</message>

<message name="getTermResponse">
<part name="value" type="xs:string"/>
</message>

<portType name="glossaryTerms">
<operation name="getTerm">
<input message=""getTermRequest"*/>
<output message=""getTermResponse"*/>
</operation>
</portType>

In the example above, the portType "glossaryTerms" defines a request-response operation called

"getTerm".

The "getTerm" operation requires an input message called "getTermRequest™ with a parameter
called "term", and will return an output message called "getTermResponse™ with a parameter

called "value".
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4. Write a program to implement to create a simple web service that converts the

temperature from Fahrenheit to Celsius (using HTTP Post Protocol)

e Creating a TemperatureApp Web Service

Open Netbeans 7.4

Open New Project > Java Web > Web Application
Type Project Name TemperatureApp

e

package org.me.temperature.

Right Click on Source Packages and add new web service TempConvertWsS with

5. Open TempConvertWS.java which is Source packages - org.me.temperature and

create web service as follows:

package org.me.temperature;

import javax.jws.WebService;
import javax.jws.WebMethod;
import javax.jws.WebParam;

@WebService(serviceName = "TempConvertWs")
public class TempConvertWs {

@WebMethod(operationName = "FtoC")

public float FtoC(@WebParam(name = "parameter™) float faren) {
float cel = (float)5/9*(faren-32);
return cel;

¥
¥

6. Now Right Click on Project Name TemperatureApp, Build and then Deploy.

7. Test the web service

Expand web services and Right click TempConvertWsS and Select Test Web Service

Or use the following url in browser.
http://localhost:8080/Temperature/ TempConvertWS?Tester

Now This Web Service TempConvertWs can be consumed as Web Based Service or

Windows application based (Stand alone) service.
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5. Write a program to implement business UDDI Registry entry

UDDI stands for Universal Description, Discovery, and Integration. The UDDI Project is
an industry initiative aims to enable businesses to quickly, easily, and dynamically find and carry
out transactions with one another.

A populated UDDI registry contains cataloged information about businesses; the services that
they offer; and communication standards and interfaces they use to conduct transactions.
Built on the Simple Object Access Protocol (SOAP) data communication standard, UDDI creates

a global, platform-independent, open architecture space that will benefit businesses.

The UDDI registry can be broadly divided into two categories:
UDDI and Web Services

UDDI and Business Registry

For details about the UDDI data structure, see UDDI Data Structure.

UDDI and Web Services
The owners of Web services publish them to the UDDI registry. Once published, the UDDI

registry maintains pointers to the Web service description and to the service.
The UDDI allows clients to search this registry, find the intended service, and retrieve its details.
These details include the service invocation point as well as other information to help identify
the service and its functionality.
Web service capabilities are exposed through a programming interface, and usually explained
through Web services Description Language (WSDL). In a typical publish-and-inquire scenario,
the provider publishes its business; registers a service under it; and defines a binding template
with technical information on its Web service. The binding template also holds reference to one
or several tModels, which represent abstract interfaces implemented by the Web service. The
tModels might have been uniquely published by the provider, with information on the interfaces
and URL references to the WSDL document.
A typical client inquiry may have one of two objectives:

e To find an implementation of a known interface. In other words, the client has a tModel

ID and seeks binding templates referencing that tModel.
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To find the updated value of the invocation point (that is., access point) of a known

binding template ID

UDDI and Business Registry

As a Business Registry solution, UDDI enables companies to advertise the business products and

services they provide, as well as how they conduct business transactions on the Web. This use of

UDDI complements business-to-business (B2B) electronic commerce.

The minimum required information to publish a business is a single business name. Once

completed, a full description of a business entity may contain a wealth of information, all of

which helps to advertise the business entity and its products and services in a precise and

accessible manner.

A Business Registry can contain:

Business Identification - Multiple names and descriptions of the business, comprehensive
contact information, and standard business identifiers such as a tax identifier.

Categories - Standard categorization information (for example a D-U-N-S business
category number).

Service Description - Multiple names and descriptions of a service. As a container for
service information, companies can advertise numerous services, while clearly displaying
the ownership of services. The bindingTemplate information describes how to access the
service.

Standards Compliance - In some cases it is important to specify compliance with
standards. These standards might display detailed technical requirements on how to use
the service.

Custom Categories - It is possible to publish proprietary specifications (tModels) that

identify or categorize businesses or services.
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UDDI Data Structure

The data structure within UDDI consists of four constructions: a businessEntity structure,

a businessService structure, a bindingTemplate structure and a tModelstructure.

import java.io.*;
importjava.util.*;

public class UDDISoapClient
{

/I Default values used if no command line parameters are set
private static final String DEFAULT_HOST_URL =
"http://localhost:8080/wasp/uddi/inquiry/";
private static final String DEFAULT_DATA_FILENAME = "./Default.xml";

/I In the SOAP chapter, we used "urn:oreilly:jaws:samples”,
// but Systinet UDDI requires this to be blank.

private static final String URI ="

private String m_hostURL;

private String m_dataFileName;

publicUDDISoapClient(String hostURL, String dataFileName) throws Exception
{
m_hostURL = hostURL,;

m_dataFileName = dataFileName;

System.out.printin( );

System.out.printin(" ");
System.out.printin(Starting UDDISoapClient:");
System.out.printin("  host url ="+ m_hostURL);
System.out.printin(" data file ="+ m_dataFileName);
System.out.printIn(" ");
System.out.printin( );

}

public void sendSOAPMessage( ) {
try {

/I Get soap body to include in the SOAP envelope from FILE
FileReaderfr = new FileReader (m_dataFileName);
javax.xml.parsers.DocumentBuilderxdb =
org.apache.soap.util.xml.XMLParserUtils.getXMLDocBuilder( );
org.w3c.dom.Document doc =
xdb.parse (new org.xml.sax.InputSource (fr));
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if (doc ==null) {
throw new org.apache.soap.SOAPEXxception
(org.apache.soap.Constants. FAULT _CODE_CLIENT, "parsing error");

¥

Il Create a vector for collecting the body elements
Vector bodyElements = new Vector( );

I/ Parse XML element as soap body element
bodyElements.add(doc.getDocumentElement ( ));

/I Create the SOAP envelope
org.apache.soap.Envelope envelope = new org.apache.soap.Envelope( );
envelope.declareNamespace("idoox", "http://idoox.com/uddiface");
envelope.declareNamespace(*'ua”, "http://idoox.com/uddiface/account™);
envelope.declareNamespace("config",

"http://idoox.com/uddiface/config");

envelope.declareNamespace(™attr", "http://idoox.com/uddiface/attr");
envelope.declareNamespace(*fxml", "http://idoox.com/uddiface/formxml™);
envelope.declareNamespace(*inner”, "http://idoox.com/uddiface/inner");
envelope.declareNamespace(™", "http://idoox.com/uddiface/inner");
envelope.declareNamespace(**uddi”, "urn:uddi-org:api_v2");

Il

/Il NO SOAP HEADER ELEMENT AS SYSTINET WASP DOES NOT REQUIRE IT

1

/I Create the SOAP body element
org.apache.soap.Body body = new org.apache.soap.Body( );
body.setBodyEntries(bodyElements);
envelope.setBody(body);

// Build and send the Message.
org.apache.soap.messaging.Messagemsg =
neworg.apache.soap.messaging.Message( );
msg.send (new java.net. URL(m_hostURL), URI, envelope);
System.out.printIn("Sent SOAP Message with Apache HTTP SOAP Client.");

/I Receive response from the transport and dumep it to the screen
System.out.printIn("Waiting for response....");
org.apache.soap.transport. SOAPTransportst = msg.getSOAPTransport ( );
BufferedReaderbr = st.receive ( );

if(line == null) {
System.out.printin(*HTTP POST was unsuccessful. \n");
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}else {

while (line '=null) {
System.out.printin (line);
line = br.readLine( );

¥

}
1

/I Version in examples has XML pretty printing logic here.
I
} catch(Exception e) {

e.printStackTrace( );

by

¥
I

/I NOTE: the remainder of this deals with reading arguments
1
[** Main program entry point. */
public static void main(String args[]) {
/I Not Relevant

}
}
Output:
Starting UDDISoapClient:
hosturl = http://localhost:8080/wasp/uddi/inquiry/
data file = Ch6_FindBusiness.xml
Sent SOAP Message with Apache HTTP SOAP Client.
Waiting for response....
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:EnvelopexmIns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<businessListxmIns="urn:uddi-org:api_v2" generic="2.0" operator="SYSTINET">
<businessinfos>
<businessinfobusinessKey="892ac280-c16b-11d5-85ad-801eef208714">
<name xml:lang="en">
Demi Credit
</name>
<description xml:lang="en">
A smaller demo credit agency used for illustrating UDDI inquiry.
</description>
<servicelnfos>
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<servicelnfo serviceKey="860eca90-c16d-11d5-85ad-801eef208714"
businessKey="9a26b6e0-c15f-11d5-85a3-801eef208714">
<name xml:lang="en">
DCAmail
</name>
</servicelnfo>
</servicelnfos>
</businessinfo>
</businessinfos>
</businessList>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
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6. Write a program to implement
a) Web based service consumer
b) Windows application based web service consumer

e Creating a Calculator Web Service

Open Netbeans 7.4

Open New Project > Java Web > Web Application

Type Project Name CalculatorApp

Right Click on Source Packages and add new web service CalculatorWS with package

org.me.calculator.

5. Open CalculatorWs.java which is Source packages - org.me.calculator and create web
service as follows:

e

package org.me.calculator;
import javax.jws.WebService;
import javax.jws.WebMethod;
import javax.jws.WebParam;
@WebService(serviceName = "CalculatorWs")
public class CalculatorWs {
@WebMethod(operationName = "add")
public int add(@WebParam(name = "a") int a, @WebParam(name = "b") int b) {
return a+b;

¥
¥

6. Now Right Click on Project Name CalculatorApp, Build and Deploy.
7. Test the web service
Expand web services and Right click CalculatorWs and Select Test Web Service
Or use the following url in browser.
http://localhost:8080/CalculatorApp/CalculatorWS?Tester
e Now This Web Service Calculatorws can Consumed as Web Based Service or Windows
application based (Stand-alone) service.
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a) Web based service consumer

CalcClientservilet IS a servlet that, like the Java client, calls the add method of the web
service. Like the application client, it makes this call through a port.

1. Open New Project - Java Web > Web Application
2. Project Name calculatorClientApp
3. Expand Web Pages = Open index.html and add a form in body tag

<body>
<form name = "submit" action ="CalcClientServlet" >

Number 1l:<input type ="text" name ="numl" value = "5">
<br/>
Number 2:<input type ="text" name ="num2" value = "6">
<br/>
<input type="submit" value = "Add" >
</form>
</body>
Now Right Click on project CalculatorClientApp and add new Web Service Client
Provide WSDL information with provided options.
Option 1 Project - browse and Select and Select CalculatorApp = CalculatorWs
Also Provide package name org.me.calculator.client
6. Right Click on Source packages and add new Servlet calcclientServiet and code as
below.

ok~
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package org.me.calculator.client;

import java.io.IOException;

import Jjava.io.PrintWriter;

import Jjavax.servlet.ServletException;

import javax.servlet.annotation.WebServlet;

import javax.servlet.http.HttpServlet;

import javax.servlet.http.HttpServletRequest;

import Jjavax.servlet.http.HttpServletResponse;

import javax.xml.ws.WebServiceRef;

@WebServlet (name = "CalcClientServlet", urlPatterns = {"/CalcClientServlet"})
public class CalcClientServlet extends HttpServlet {

@WebServiceRef (wsdlLocation =

"http://localhost:8080/CalculatorAppl/CalculatorWS?wsdl")

public org.me.calculator.client.CalculatorWS_Service service;

protected void processRequest (HttpServletRequest request,

HttpServletResponse response)throws ServletException, IOException {

response.setContentType ("text/html;charset=UTF-8") ;
try (PrintWriter out = response.getWriter()) {

CalculatorWS port = service.getCalculatorWSPort() ;

int i = Integer.parselnt (request.getParameter ("numl"));
int j Integer.parselnt (request.getParameter ("num2"));
int res = port.add(i, j):

out.println ("<html>");

out.println ("<head>");

out.println("<title>Servlet CalcClientServlet</title>");

out.println ("</head>");

out.println ("<body>");

out.println ("<hl>Servlet CalcClientServlet at " +
request.getContextPath () + "</h1>");

out.println ("<br/> Result <br/>" + i + " + " + J + " =" + res );

out.println ("</body>");

out.println ("</html>");

} // end of try block

} // end of processRequest method
} // end of CalcClientServlet

7. Now Build and then Deploy
8. Finally Run the CalculatorClientApp, which opens index.html in default web browser.
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b) Windows application based web service consumer

=

Open New Project - Java - Java Application
2. Project Name CalcclientApp

w

Now Right Click on project CalcClientApp and add new Web Service Client
4. Provide WSDL information with provided options.
Option 1 Project - browse and Select and Select CalculatorApp - CalculatorWs
Also provide package name org.me.calcclient
5. Open Source packages and add new Servlet calcclientapp.java and code as below.
package calcclient;

public class CalcClientApp {
public static void main(String[] args) {
try {
System.out.printin("Result =" + add(7,5));
}catch(Exception ex) {
System.out.printin(ex);

}

}

private static int add(int i, int j) {
org.me.calculator.CalculatorWSService service = new

org.me.calculator.CalculatorWSService();

org.me.calculator.CalculatorWs port = service.getCalculatorWSPort();
return port.add(i, j);

}

}

6. Now Build and then Deploy
7. Finally Run the CalclientApp.
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Getting Started with JAX-WS Web Services

Java API for XML Web Services (JAX-WS), JSR 224, is an important part of the Java EE
platform. A follow-up to the release of Java API for XML-based RPC 1.1(JAX-RPC), JAX-WS
simplifies the task of developing web services using Java technology. It addresses some of the
issues in JAX-RPC 1.1 by providing support for multiple protocols such as SOAP 1.1, SOAP
1.2, XML, and by providing a facility for supporting additional protocols along with HTTP.
JAX-WS uses JAXB 2.0 for data binding and supports customizations to control generated
service endpoint interfaces. With its support for annotations, JAX-WS simplifies web service
development and reduces the size of runtime JAR files.

This document demonstrates the basics of using the IDE to develop a JAX-WS web service.
After you create the web service, you write three different web service clients that use the web
service over a network, which is called "consuming"” a web service. The three clients are a Java
class in a Java SE application, a servlet, and a JSP page in a web application. A more advanced
tutorial focusing on clients is Developing JAX-WS Web Service Clients.

We use the following software and resources.

Software or Resource Version Required
NetBeans IDE Java EE download bundle
Java Development Kit (JDK) JDK 7 or JDK 8

. o GlassFish Server Open Source Edition
Java EE-compliant web or application server .
Oracle WebLogic Server

Note: The GlassFish server can be installed with the Java EE distribution of NetBeans IDE.
Alternatively, you can visit the the GlassFish server downloads page or theApache Tomcat
downloads page.

Important: Java EE projects require GlassFish Server or Oracle WebLogic Server 12c.

Enabling Access to External Schema

You need to enable the IDE and the GlassFish Server to access external schema to parse the
WSDL file of the web service. To enable access you need to modify the configuration files of the
IDE and the GlassFish Server. For more details, see the FAQ How to enable parsing of WSDL
with an external schema?

Configuring the IDE

To generate a web service client in the IDE from a web service or WSDL file you need to
modify the IDE configuration file (netbeans.conf) to add the following switch
tonetbeans_default_options.

-J-Djavax.xml.accessExternalSchema=all

For more about locating and modifying the netbeans.conf configuration file, see Netbeans Conf

FAQ.
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Configuring the GlassFish Server

If you are deploying to the GlassFish Server you need to modify the configuration file of the
GlassFish Server (domain.xml) to enable the server to access external schemas to parse the wsdl
file and generate the test client. To enable access to external schemas, open the GlassFish
configuration file (GLASSFISH_INSTALL/glassfish/domains/domainl1/config/domain.xml)
and add the following JVM option element (in bold). You will need to restart the server for the
change to take effect.

</java-config>

<jvm-options>-Djavax.xml.accessExternalSchema=all</jvm-options>

</java-config>

Creating a Web Service Using NetBeans 7.4

The goal of this exercise is to create a project appropriate to the deployment container that you
decide to use. Once you have a project, you will create a web service in it.

Choosing a Container
You can either deploy your web service in a web container or in an EJB container. This depends
on your choice of implementation. If you are creating a Java EE application, use a web container
in any case, because you can put EJBs directly in a web application. For example, if you plan to
deploy to the Tomcat Web Server, which only has a web container, create a web application, not
an EJB module.
1. Choose File > New Project (Ctrl-Shift-N on Linux and Windows, 38-Shift-N on
MacOS). Select Web Application from the Java Web category or EJB Module from the
Java EE category.

Note. You can create a JAX-WS web service in a Maven project. Choose File > New
Project (Ctrl-Shift-N on Linux and Windows, 38-Shift-N on MacOS) and then Maven
Web Application or Maven EJB module from the Maven category. If you haven't used
Maven with NetBeans before, see Maven Best Practices.

2. Name the project CalculatorWSApplication. Select a location for the project. Click Next.

3. Select your server and Java EE version and click Finish.

Note. To use the Oracle WebLogic server, register the server with the IDE. Also, if you
are using the WebLogic server, watch the screencast on Deploying a Web Application to
Oracle WebLogic.
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Creating a Web Service from a Java Class
1. Right-click the CalculatorWSApplication node and choose New > Web Service.

2. Name the web service CalculatorWs and type org.me.calculator in Package. Leave
Create Web Service from Scratch selected.

3. If you are creating a Java EE project on GlassFish or WebLogic, select Implement Web
Service as a Stateless Session Bean.

Steps Mame and Location

1. Choose File Type Web Service Mame: |Calculatu:-r'-.-'-.-'5 |
2. MName and Location

Project: |Calculatu:ur'-.-'-.-'5.ﬁ.pplicati|:-n |

Lacation: |S|:|urce Packages b |

Package: |Drg.me.calcuatnr w |

(%) Create \Webh Service from Scratch

) Create Webh Service from Existing Session Bean

Enterprise Bean: Erowse, ..

o e Implement Web Service as Stateless Session Bean

& R e

Mext = [ Finish H Cancel H Help ]

4. Click Finish. The Projects window displays the structure of the new web service and the
source code is shown in the editor area.

Adding an Operation to the Web Service

The goal of this exercise is to add to the web service an operation that adds two numbers
received from a client. The NetBeans IDE provides a dialog for adding an operation to a web
service. You can open this dialog either in the web service visual designer or in the web service
context menu.

Warning: The visual designer is not available in Maven projects.

To add an operation to the web service:
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. Either: Change to the Design view in the editor.
| Calculatorw's. java x] ER =)
source |{Dzgiar || ristory [ [ o2k SR
CalculatorVWs
Operations | Add Operation... 1
=2 hello ISIREERES
Parameters Cutput Faults Description
FParameter MName Parameter Type
name Java. lang.String
Quality OFf Service
I Optimize Transfer OFf Binary Data (MTOM)
 Reliable Message Delivery
N Secure Service
[ Edit Web Service Attributes ... |

Or:

Find the web service's node in the Projects window. Right-click that node. A context

menu opens.

| Projects a0 x| |Files

@ cdiDemo

I':'I@J Maven Calculakor Service
I:a web Pages
EI-% Web Services
CalculatorService
EE| Sout Dpen

-- & Dem Add Operation. ..
-- Tesk
: s . Test Web Service
m Proj

Edit Web Service Attributes

Configure Handlers, .,

e — Delete
| CalculatorServi

Properties

Click Add Operation in either the visual designer or the context menu. The Add

Operation dialog opens.

In the upper part of the Add Operation dialog box, type add in Name and type int in the

Return Type drop-down list.

In the lower part of the Add Operation dialog box, click Add and create a parameter of

type int named i.
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You now see the following:

-

AddiopeEration...

Marm e: |a|:h:|

Return Type: |int

l/F'arameters [ Exceptions

LS

Mam e Type Firnal
[ int |
i it |:| Eemove
Up
[ ot
]9 Cancel

-
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Click OK at the bottom of the Add Operation dialog box. You return to the editor.

Remove the default hello operation, either by deleting the hello() method in the source
code or by selecting the hellooperation in the visual designer and clicking Remove Operation.
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The visual designer now displays the following:

@index.jsp = CalculatDrWS.java x] |II|E]@
== ™

CalculatorWwsService

Operations | Add Operation... | | |
(<= add EHE=EE=E
Parameters Cutput Faults Description

Parameter Mame Parameter Type
i int
i int

Quality Of Service
1 Optimize Transfer Of Binary Data (MTOM)
I Reliable Message Delivery
[ Secure Service
| Advanced ...

Click Source and view the code that you generated in the previous steps. It differs
whether you created the service as an Java EE stateless bean or not. Can you see the difference in
the screenshots below? (A Java EE 6 or Java EE 7 service that is not implemented as a stateless
bean resembles a Java EE 5 service.)
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b

package org.me.calculator;

Amport javax.jws . kebMethod;
Aimport javasx.jws.kWebFaram;
Amport javax.jws . kebService;

JJ/WW
W
* dauthor gwlS27?71
"
AnehService ]
public class CalculatorWS

— —0

J-I/WW
* kleb service operation
W
ArebMethod{operationMane = "add™)
public int add{@JebFaram{name = "1")
int 1, @debParami{name = "77)
int 2 {

AETODD write wour dmplementation code here:

return O;

—

¥

T
[4] Il [»]

[l

rackage org.me.calcuator;

[l import javax.jws.WebMethod;
import Javax.jws.lUebParam:
import Jjawvax.jws.Wehlerwvice:

= dmport Javax.ejbh.Ztatelezss:

E ww

+*

* @Fauthor Jjeff

L *7

Alekh3ervice ()

f3tateless ()

pubhlic class CalculatorWs |

l.."'.’q.".’q.‘

* Wekh service operation

*y
AWebMethod (operationMame = Tadd™)
public int add(EVWebParamnsme = "i™)
int i, [WehParaminame = "717)

int 3 4

SATODD write wour implementation code
return 0O;
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Note. In NetBeans IDE 7.3 and 7.4 you will notice that in the

generated @WebService annotation the service name is specified explicitly:
@WebService (serviceName = "CalculatorWsS").

In the editor, extend the skeleton add operation to the following (changes are in bold):

@WebMethod
public int add(@WebParam(name = "i") int i, @WebParam(name = "j")int 7J)
{
int k = i + j;
return k;
}
As you can see from the preceding code, the web service simply receives two numbers and then
returns their sum. In the next section, you use the IDE to test the web service.

Deploying and Testing the Web Service

After you deploy a web service to a server, you can use the IDE to open the server's test client, if
the server has a test client. The GlassFish and WebLogic servers provide test clients.

If you are using the Tomcat Web Server, there is no test client. You can only run the project and
see if the Tomcat Web Services page opens. In this case, before you run the project, you need to
make the web service the entry point to your application. To make the web service the entry
point to your application, right-click the CalculatorWSApplication project node and choose
Properties. Open the Run properties and type /CalculatorWs in the Relative URL field. Click
OK. To run the project, right-click the project node again and select Run.

To test successful deployment to a GlassFish or WebLogic server:

1. Right-click the project and choose Deploy. The IDE starts the application server, builds
the application, and deploys the application to the server. You can follow the progress of
these operations in the CalculatorWSApplication (run-deploy) and the GlassFish server
or Tomcat tabs in the Output view.
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2. Inthe IDE's Projects tab, expand the Web Services node of the CalculatorWSApplication
project. Right-click the CalculatorWsS node, and choose Test Web Service.

: Projects a0 22 | Services
EI@ CalculatorwsApplication
E| & Web Pages
o @l wEB-INF
. @ iI'ldEX.jSp

-l [m Web Services
Open
" @ Con Refresh Service
gl Sery
Bt [ Sou Audd Operation...
Bt Tes
G- B Libr) Test Web Service
=g Tesl

Edit Web Service Attributes

Configure Handlers...

Generate and Copy WSDL...

Delete Delete

Properties

The IDE opens the tester page in your browser, if you deployed a web application to the
GlassFish server. For the Tomcat Web Server and deployment of EJB modules, the
situation is different:

If you deployed to the GlassFish server, type two numbers in the tester page, as shown
below:

CalculatorWsS Web Service Tester

This form will allow you to test your web service implementation (W SDL File)

To tvoke an operation, fill the method parameter(s) mput boxes and click on
the button labeled with the method name.

Methods :

public abstract int org netbeans Calculator™W =Project. add(int int)
add | (|2 1] )

The sum of the two numbers is displayed:
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add Method invocation

Method parameter(s)

Type [Value
w2
o [

Method retumed

mt ; "S"
P,
by

Samples

You can open a complete Java EE stateless bean version of the Calculator service by choosing
File > New Project (Ctrl-Shift-N on Linux and Windows, 38-Shift-N on MacOS) and navigating
to Samples > Web Services > Calculator (EE6).

A Maven Calculator Service and a Maven Calculator Client are available in Samples > Maven.

Consuming the Web Service

Now that you have deployed the web service, you need to create a client to make use of the web
service's add method. Here, you create three clients— a Java class in a Java SE application, a
servlet, and a JSP page in a web application.

Note: A more advanced tutorial focusing on clients is Developing JAX-WS Web Service
Clients.

Client 1: Java Class in Java SE Application

In this section, you create a standard Java application. The wizard that you use to create the
application also creates a Java class. You then use the IDE's tools to create a client and consume
the web service that you created at the start of this tutorial.

1. Choose File > New Project (Ctrl-Shift-N on Linux and Windows, 38-Shift-N on
MacOS). Select Java Application from the Java category. Name the
projectcalculatorWs Client Application. Leave Create Main Class selected and
accept all other default settings. Click Finish.
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2. Right-click the CalculatorWS Client Application node and choose New > Web Service Client.

The New Web Service Client wizard opens.

3. Select Project as the WSDL source. Click Browse. Browse to the CalculatorWS web service in the

CalculatorW SApplication project. When you have selected the web service, click OK.
® 7 O Browse Web Services

Web Services:

v @ CalculatorwsApplication

> Calculatorws

| Cancel | [ OK |

4. Do not select a package name. Leave this field empty.

ano Mew Web Service Client

Steps WSDL and Client Location

1. Choose File Type Specify the WSDL file of the Web Service.

2. W5DL and Client

Location (*) Project: os1: 8080/ Calculatorws /Calculatorwstwsdl Erowse...

. ) Lacal File: Browse,,
) WSDL URL:
\_J IDE Registered: Browse..

Specify a package name where the client java artifacts will be generated:
Project: Calculatertys_Client_Application

Package: |

Cenerate Dispatch code

Help < Back Mext = | Finish !, Cancel

5. Leave the other settings at default and click Finish.
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The Projects window displays the new web service client, with a node for the add method that you created:

:Projects a

[lj@ CalculatorWs_Client_Application

E}IE Source Packages

-5 META-TNF

EE] META-IMNF . wsdl localhost_3080. Calculatoriaes

EIEEI calculatorws_client_application
@a(:alculatl:ur'-.-'-.-'S_CIient_.ﬁ.ppIil:aI:h:un.java

}@
—1-I[(@ Weh Service References
EI Calculatorth's
Eiﬁ Calculatory's
-8 CalculatorwsPart
o

int... =

L@ Libraries
I'_—'I@ CalculatorwSapplication

6. Double-click your main class so that it opens in the Source Editor. Drag the add node below

themain () method.
=-EF CalculatarwsSPort |-
@ R 11 public class CaleculatorWs CC

‘v @ hela 1z

raries 13 .
*
itorwSapplication w L Gparam args the comm

15 L
tor \\ﬂ\x 16 public static void main

7 ff TODD code applic:
18 i

19 |

20 H

You now see the following:
public static void main(String[] args) {
// TODO code application logic here
}
private static int add(int i, int j) {
org.me.calculator.CalculatorWS Service service = new
org.me.calculator.CalculatorWS Service();
org.me.calculator.CalculatorWsS port =
service.getCalculatorWSPort () ;
return port.add(i, j);
}
Note: Alternatively, instead of dragging the add node, you can right-click in the editor and then choose

Insert Code > Call Web Service Operation.
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Inthemain () method body, replace the TODO comment with code that initializes values for i and 7,
calls add (), and prints the result.

public static void main (String[] args) {
int 1 = 3;
int 3 = 4;
int result = add(i, j):
System.out.println ("Result = " + result);
}
Surround the main () method code with a try/catch block that prints an exception.

public static void main (String[] args) {

try {
int 1 = 3;
int j = 4;

int result = add(i, j):

System.out.println ("Result = " + result);
} catch (Exception ex) {

System.out.println ("Exception: " + ex);

}
Right-click the project node and choose Run.

The Output window now shows the sum:
compile:
run:
Result = 7
BUILD SUCCESSFUL (total time: 1 second)

Client 2: Servilet in Web Application

In this section, you create a new web application, after which you create a servlet. You then use the servlet to

consume the web service that you created at the start of this tutorial.

1.

Choose File > New Project (Ctrl-Shift-N on Linux and Windows, 3&Shift-N on MacOS). Select Web
Application from the Java Web category. Name the project CalculatorWSServletClient. Click Next

and then click Finish.

Right-click the CalculatorWSServletClient node and choose New > Web Service Client.

The New Web Service Client wizard opens.
Select Project as the WSDL source and click Browse to open the Browse Web Services dialog box.
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4. Select the CalculatorWs web service in the CalculatorW SApplication project. Click OK to close the Browse

Web Services dialog box.
® O O  Browse Web Services

Web Services:

v & CaleulatorWsSApplication

(2 Calculatorws

| Cancel | [ 0K ]

5. Confirm that the package name is empty in the New Web Service Client wizard and leave the other settings
at the default value. Click Finish.

The Web Service References node in the Projects window displays the structure of your newly created
client, including the addoperation that you created earlier in this tutorial.
6. Right-clickthe CalculatorWSServletClient project node and choose New > Servlet. Name the

servletClientServlet and place it in a package called org.me.calculator.client. Click Finish.

7. To make the servlet the entry point to your application, right-click the CalculatorwSServletClient project
node and choose Properties. Open the Run properties and type /ClientServlet in the Relative URL

field. Click OK.

8. Ifthere are erroricons for ClientServlet. java, right-click the project node and select Clean and
Build.

9. IntheprocessRequest () method, add some empty lines after this line:

out.println("<hl>Servlet ClientServlet at " +
request.getContextPath () + "</hl>");
10. In the Source Editor, drag the add operation anywhere in the body of the ClientServlet class.
The add () method appears at the end of the class code.

Note: Alternatively, instead of dragging the add node, you can right-click in the editor and then choose
Insert Code > Call Web Service Operation.
private int add(int i, int j) {

org.me.calculator.CalculatorWsS port =
service.getCalculatorWSPort () ;

return port.add(i, j);
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11. Add code that initializes values for i and 7, calls add (), and prints the result. The added code is

in boldface:

protected void processRequest (HttpServletRequest request,
HttpServletResponse response)
throws ServletException, IOException {
response.setContentType ("text/html;charset=UTF-8") ;
PrintWriter out = response.getWriter():;
try {
out.println ("<html>") ;
out.println ("<head>");
out.println("<title>Servlet ClientServlet</title>");
out.println ("</head>");
out.println ("<body>");
out.println ("<hl>Servlet ClientServlet at "

+request.getContextPath () + "</hl>");
inti=3;
intj = 4;

int result = add(i, j);
out.println("Result = " + result);

out.println ("</body>");
out.println ("</html>");

} finally {
out.close () ;
}
}

12. Surround the added code with a try/catch block that prints an exception.

protected void processRequest (HttpServletRequest request,
HttpServletResponse response)
throws ServletException, IOException ({
response.setContentType ("text/html;charset=UTF-8") ;
PrintWriter out = response.getWriter();
try {
out.println ("<html>") ;
out.println ("<head>");
out.println("<title>Servlet ClientServlet</title>");
out.println ("</head>");
out.println ("<body>");
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out.println ("<hl>Servlet ClientServlet at " +

request.getContextPath () + "</hl>");
try {
int 1 = 3;
int 3 = 4;

int result = add(i, j):
out.println ("Result = " + result);
} catch (Exception ex) {

out.println("Exception: " + ex);

out.println ("</body>");
out.println("</html>");

} finally {
out.close();

}
13. Right-click the project node and choose Run.

The server starts, the application is built and deployed, and the browser opens, displaying the calculation

result, as shown below:

Servlet ClientServlet at
/CalculatorWSServletClient

Result =7

Client 3: JSP Page in Web Application

In this section, you create a new web application and then consume the web service in the default JSP page that the
Web Application wizard creates.
Note: If you want to run a JSP web application client on Oracle WebLogic, see Running a Java Server Faces 2.0

Application on WebLogic.
1. Choose File > New Project (Ctrl-Shift-N on Linux and Windows, 3&Shift-N on MacOS). Select Web
Application from the Java Web category. Name the project CalculatorWSJSPClient. Click Next and

then click Finish.
2. Expand the Web Pages node under the project node and delete index.html.
3. Right-click the Web Pages node and choose New > JSP in the popup menu.

If JSP is not available in the popup menu, choose New > Other and select JSP in the Web category of the
New File wizard.
4. Type index for the name of the JSP file in the New File wizard. Click Finish.
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5. Right-clickthe CalculatorWSJSPClient node and choose New >Web Service Client.

6. Select Project as the WSDL source. Click Browse. Browse to the CalculatorWS web service in the

CalculatorW SApplication project. When you have selected the web service, click OK.
® O O  Browse Web Services

Web Services:

v & CaleulatorwSApplication

[ Calculatorws

| Cancel | [ 0K ]

7. Do not select a package name. Leave this field empty.
8. Leave the other settings at default and click Finish.

The Projects window displays the new web service client, as shown below:
:Projects 4l
=@ calculatorwsIspClient
E}@ Web Pages
- E-) WEB-INF
: - @ inde. jsp
@ Source Packages
B
[ﬁ Libraries
E}@ Web Service References
EI Caleulatoria's

E}i Caloulatory's

=@ CalculatorwsPart
@ R

E}-@ Configuration Files

9. Inthe Web Service References node, expand the node that represents the web service. The add operation,

which you will invoke from the client, is now exposed.

10. Drag the add operation to the client's index. jsp page, and drop it below the H1 tags. The code for
invoking the service's operation is now generated in the index . jsp page, as you can see here:
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<%
try {
org.me.calculator.CalculatorWSService service = new
org.me.calculator.CalculatorWSService () ;
org.me.calculator.CalculatorWS port =
service.getCalculatorWSPort () ;
// TODO initialize WS operation arguments here
int 1 = 0;
int j = 0;
// TODO process result here
int result = port.add(i, j):
out.println ("Result = "+result);
} catch (Exception ex) {
// TODO handle custom exceptions here
}
&>
Change the value for 1 and 7 from 0 to other integers, such as 3 and 4. Replace the commented out TODO
line in the catch block with out .println ("exception" + ex) ;.

11. Right-click the project node and choose Run.

The server starts, if it wasn't running already. The application is built and deployed, and the browser opens,
displaying the calculation result:

Hello World!

Result=7
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